Aankondiging vervanging PHP 5.3 en beschikbaarheid PHP 7

Alle klanten zijn per email geïnformeerd over de updates die wij in 2016 zullen doorvoeren aan de PHP versies op onze webhostingpakketten.

Wat is PHP? PHP is de computertaal waarin veel websites worden geschreven, denk aan WordPress, Joomla, Magento of Drupal maar mogelijk ook uw zelf ontwikkelde website.

Op dit moment bieden wij PHP versie 5.3 als standaard versie aan en kunt u als klant via het DirectAdmin controle paneel uw website omzetten naar PHP versie 5.6. De ondersteuning voor PHP 5.3 is echter sinds midden 2015 verlopen wat betekend dat er bijvoorbeeld geen beveiligingsupdates meer worden uitgebracht voor deze versie.

Om deze reden zullen wij in juli 2016 alle webhostingpakketten overzetten naar PHP 5.6, PHP 5.3 zal daarna als optionele versie beschikbaar blijven tot januari 2017. Per januari 2017 zal PHP 5.3 worden vervangen door PHP versie 7.0 (PHP 5.6 blijft op dat moment nog de standaard versie).

Samengevat:
Huidig: PHP 5.3 standaard, PHP 5.6 optioneel
Per 1 juni 2016: PHP 5.6 standaard, PHP 5.3 optioneel
Per 1 januari 2017: PHP 5.6 standaard, PHP 7.0 optioneel

Wat moet u doen?
Om er zeker van te zijn dat uw website na 1 juni 2016 nog werkt dient u te controleren of uw website geschikt is voor PHP 5.6. U kunt dit zelf testen door via het DirectAdmin controle paneel uw domeinnaam over te zetten naar PHP 5.6. De volgende handleiding laat u stap voor stap zien hoe: https://www.myh2oservers.com/php-versie-kiezen-binnen-directadmin
Na het omzetten dient u uw website goed te controleren (alle pagina’s en functies) om er zeker van te zijn dat uw website nog correct functioneert.

Mocht u zelf geen kennis hebben over dit onderwerp schakel dan uw websitebeheerder in, hij/zij kan u hierbij helpen. Heeft u geen contact meer met uw websitebeheerder? Neem dan contact met ons op zodat wij u in contact kunnen brengen met onze partner voor website gerelateerde werkzaamheden.

Gebruikt u Joomla 1.x of 2.x voor uw website?
Joomla 1.5, 1.6 en 1.7 worden door Joomla sinds 2012 niet meer ondersteund en de ondersteuning voor versie 2.x is per eind 2014 komen te vervallen. Technisch werken deze websites op dit moment nog wel. Met de wijziging van 1 juni 2016 zullen Joomla 1.5 websites echter niet meer werken en met het gebruik van versie 2.x loopt u een risico op inbraak/misbruik van uw website via gaten in de Joomla software. Wij raden u aan om, indien u Joomla 1.x of 2.x gebruikt, uw website te migreren naar de meest recente Joomla versie (of een ander CMS als WordPress). Indien nodig kan uw websitebeheerder hier meer over vertellen (heeft u daar geen contact meer mee? Neem dan contact op met ons).

Mocht u uw Joomla 1.5 website niet voor 1 juli 2016 kunnen migreren naar een hogere versie dan kunt u (nadat wij de standaard versie hebben omgezet) uw website terug zetten naar PHP 5.3 (de optionele versie) via eerder genoemde handleiding. Uw website zal dan weer werken. Houd u er echter rekening mee dat PHP 5.3 per januari 2017 geheel komt te vervallen en er dan geen alternatieve oplossing meer beschikbaar is.

Laat een reactie achter